Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существу- ет две команды: Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в на- правлении движения; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что по- следовательность команд в скобках повторится k раз. При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник?
1) Повтори 3 [Вперёд 50 Направо 20 Направо 25]
2) Повтори 3 [Вперёд 50 Направо 100 Направо 20]
3) Повтори 6 [Вперёд 50 Направо 10 Направо 20]
4) Повтори 6 [Вперёд 50 Направо 20 Направо 40]


Ответ 4 так как направо 20 и ещё раз направо 40 в сумме 60 в правильном треугольнике угол равен 60

Оцени ответ

Загрузить картинку
Не нашёл ответ?

Если тебя не устраивает ответ или его нет, то попробуй воспользоваться поиском на сайте и найти похожие ответы по предмету Информатика.

Найти другие ответы

ПОИСК ПО САЙТУ



ПРЕДМЕТЫ

Показать ещё